Veränderungen nicht möglich

Copied from BlueSpice free / Discussion / Help: Veränderungen nicht möglich

Hallo,

ich habe die aktuelle Version von Bluespice free auf meinem Server aufgesetzt.
Ich logge mich ein, klicke auf das bearbeiten Symbol auf der Hauptseite. Dann kommt ein Ladebalken der bei geschätzten 75% hängen bleibt und sich weigert weiter zu machen.
Ebenso wenn ich irgendwoanders auf einen solchen Button klicke, es kommt immer derselbe Ladebalken mit demselben Fortschritt.

Danke für die Hilfe.

Hallo!

Hierbei handelt es sich vermutlich um irgendeinen JavaScript-Fehler, welcher beim Laden des VisualEditor auftritt. Bitte mal mittels F12-Taste die “Entwicklerwerkzeuge” des Browsers öffnen, und dann den Fehler reprodutieren.
Im Reiter “Konsole” müsste eine Fehlermeldung erscheinen. Bitte diese hier teilen.

Hallo zusammen,

ich habe das selbe Problem.
Ich habe ein frisches Bluespice 4.4.2 aufgesetzt und bei jeder Seite die ich editieren oder erstellen möchte lädt der Editor nicht vollständig - er bleibt bei etwa 75% stehen.
Es ist hierbei egal ob man den visuellen oder den Quelltexteditor nutzt.

Wie vorgeschlagen hier einmal die Fehlermeldungen die in der Konsole erscheinen, wenn eine Seite neu angelegt wird:

GET
http://[[Server-IP]]/w/index.php?title=Test&veaction=edit&preload=&redlink=1
[HTTP/1.1 404 Not Found 203ms]

Content-Security-Policy: Ignorieren von "'unsafe-inline'" innerhalb script-src: nonce-source oder hash-source angegeben index.php
Content-Security-Policy: Die Einstellungen der Seite haben das Laden einer Ressource auf inline blockiert ("script-src"). index.php:27:204
Einige Cookies verwenden das empfohlene "SameSite"-Attribut inkorrekt. 18
Passing a selector to infuse is deprecated. Use an HTMLElement or jQuery collection instead. 2 load.php:324:77
Passing a selector to infuse is deprecated. Use an HTMLElement or jQuery collection instead. load.php:324:77
[ef540a0fa11c3328795ea409] 2024-04-04 18:29:56: Fatal exception of type "RuntimeException" load.php:4:48
    <anonym> http://[[Server-IP]]/w/load.php?lang=de&modules=ext.bluespice.checkbox.visualEditor|ext.bluespice.checklist.visualEditor|ext.bluespice.countthings.visualEditorTagDefinition|ext.bluespice.extendedstatistics.visualEditorTagDefinition|ext.bluespice.pageaccess.visualEditorTagDefinition|ext.bluespice.pagesvisited.visualEditorTagDefinition|ext.bluespice.qrCode.visualEditor|ext.bluespice.tagcloud.visualEditorPlugin|ext.bluespice.universalExport.visualEditorTagDefinition|ext.bluespice.watchlist.visualEditor|ext.bluespice.whoisonlinecount.visualEditorTagDefinition|ext.bluespice.whoisonlinepopup.visualEditorTagDefinition&skin=bluespicediscovery&version=r0zd7:4
ContentDroplets: Required RL modules failed to load index.php:27:35
    _doLoad http://[[Server-IP]]/w/index.php?title=Test&veaction=edit&preload=&redlink=1 line 10 > injectedScript:27
    jQuery 3
        fire
        fireWith
        tuple[0]
    doPropagation http://[[Server-IP]]/w/load.php?lang=de&modules=startup&only=scripts&raw=1&skin=bluespicediscovery:6
    (Async: requestIdleCallback handler)
    setAndPropagate http://[[Server-IP]]/w/load.php?lang=de&modules=startup&only=scripts&raw=1&skin=bluespicediscovery:7
    implement http://[[Server-IP]]/w/load.php?lang=de&modules=startup&only=scripts&raw=1&skin=bluespicediscovery:18
    <anonym> http://[[Server-IP]]/w/load.php?lang=de&modules=ext.bluespice.distribution.droplet.circlednumber,createInput,gallery,map,pdflink,subpages|ext.bluespice.distribution.object.buttonlink|ext.bluespice.distribution.video.visualEditor|ext.bluespice.smartList.dropelts.toplist|ext.bluespice.smartList.droplets.newbies,recentchanges,whatlinkshere|ext.bluespice.smartList.userlist.visualEditor|ext.contentdroplets.droplets.icon,text|ext.enhancedupload.attachments.bootstrap|ext.forms.define,formelements,standalone,widgets|ext.forms.formelements.bootstrap|ext.oOJSPlus.formelements|mediawiki.widgets.TitlesMultiselectWidget&skin=bluespicediscovery&version=1gwh3:1
unreachable code after return statement

Vielen Dank
Michael

Hallo und willkommen im BlueSpice Community-Forum Tyril!

Danke für die Fehlermeldung. Sehe ich das richtig so, dass es sich hierbei um eine klassische Installation handelt und nicht um das Docker-Image?

ContentDroplets: Required RL modules failed to load

Gibt es im Netzwek-Panel der Browser-Developer-Tools irgendwelche Auffälligkeiten? Zum Beispiel Status-Codes 404, 403, 401 oder 500?

Gibt es in den PHP Error Logs auf dem Server irgendetwas?

Hallo rvogel,

vielen Dank für deine schnelle Antwort.

Es handelt sich um eine klassische Installation auf einem Debian 11.

Im Netzwerkverlauf gibt es keine Auffälligkeiten.
Es gibt keine Anfragen mit irgendwelchen Fehlercodes.
Alles wird mit einem Code 200 erfolgreich quitiert.

In den PHP Logs steht in den “error-bluespice.log” folgende Anmerkung:

[Fri Apr 05 13:35:18.330686 2024] [php7:notice] [pid 641] [client [[Client-IP]]:50075] PHP Notice: Undefined index: pt_tags in /var/www/bluespice/w/extensions/BlueSpicePageTemplates/includes/BSPageTemplateList.php on line 257, referer: http://[[Server-IP]]/w/index.php?title=Test&action=view

Ansonsten gibt es keine auffälligen Logs.
Vollständigkeitshalber hier aber noch das access-bluespice.log:

[[Client-IP]] - - [05/Apr/2024:13:35:18 +0200] "GET /w/index.php?title=Test&veaction=edit&preload=&redlink=1 HTTP/1.1" 404 45924 "http://[[Server-IP]]/w/index.php?title=Test&action=view" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:124.0) Gecko/20100101 Firefox/124.0"
[[Client-IP]] - - [05/Apr/2024:13:35:18 +0200] "GET /w/load.php?lang=de&modules=ext.bluespice.compat.vector.styles%7Cext.bluespice.insertcategory.discovery.styles%7Cext.bluespice.pageTemplates.standardtemplate.styles%7Cext.bluespice.pageTemplates.styles%7Cext.bluespice.styles%7Cext.bluespice.visualEditorConnector.colors%2Ctables%7Cext.echo.styles.badge%7Cext.pagea
ssignments.styles%7Cext.visualEditor.desktopArticleTarget.noscript%7Cmediawiki.pager.styles%7Cmediawiki.widgets.styles%7Coojs-ui-core.icons%2Cstyles%7Coojs-ui.styles.icons-alerts%2Cindicators%7Cskin.discovery.aftercontent.styles%7Cskin.discovery.back-to-top.styles%7Cskin.discovery.bluespice.styles%7Cskin.discovery.bluespice.themes.default%7Cskin.discovery.bootstr
ap.styles%7Cskin.discovery.footer.styles%7Cskin.discovery.main.styles%7Cskin.discovery.mw.skinning.interface%7Cskin.discovery.navbar-primary.styles%7Cskin.discovery.sidebar-primary.styles%7Cskin.discovery.sidebar-secondary.styles%7Cskin.discovery.skip-links.styles&only=styles&skin=bluespicediscovery HTTP/1.1" 200 97412 "http://[[Server-IP]]/w/index.php?title=Tes
t&veaction=edit&preload=&redlink=1" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:124.0) Gecko/20100101 Firefox/124.0"
[[Client-IP]] - - [05/Apr/2024:13:35:18 +0200] "POST /w/api.php?action=cspreport&format=json HTTP/1.1" 200 456 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:124.0) Gecko/20100101 Firefox/124.0"
[[Client-IP]] - - [05/Apr/2024:13:35:18 +0200] "GET /w/load.php?lang=de&modules=startup&only=scripts&raw=1&skin=bluespicediscovery HTTP/1.1" 200 16093 "http://[[Server-IP]]/w/index.php?title=Test&veaction=edit&preload=&redlink=1" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:124.0) Gecko/20100101 Firefox/124.0"
[[Client-IP]] - - [05/Apr/2024:13:35:18 +0200] "GET /w/api.php?action=visualeditor&format=json&paction=parse&page=Test&uselang=de&preload=&formatversion=2 HTTP/1.1" 200 2163 "http://[[Server-IP]]/w/index.php?title=Test&veaction=edit&preload=&redlink=1" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:124.0) Gecko/20100101 Firefox/124.0"
[[Client-IP]] - - [05/Apr/2024:13:35:19 +0200] "GET /w/rest.php/contentdroplets/droplets HTTP/1.1" 200 15233 "http://[[Server-IP]]/w/index.php?title=Test&veaction=edit&preload=&redlink=1" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:124.0) Gecko/20100101 Firefox/124.0"
[[Client-IP]] - - [05/Apr/2024:13:35:19 +0200] "GET /w/load.php?lang=de&modules=ext.bluespice.watchlist.visualEditor%7Cext.forms.widgets&skin=bluespicediscovery&version=7evqc HTTP/1.1" 200 20216 "http://[[Server-IP]]/w/index.php?title=Test&veaction=edit&preload=&redlink=1" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:124.0) Gecko/20100101 Firefox/124.0"

Noch ergänzend:

Ich hab noch unter /etc/php/7.4/apache2/php.ini das Logging eingeschaltet. Es entstehen keine Fehlermeldungung wenn der Editor lädt.

Wenn ich die ContentDroplets Extension aus der 001-BlueSpiceDistribution.php auskommentiere, lädt der Editor. Die Extension benötige ich aber natürlich.