Problem with search in BlueSpice

Hi

I rencently installed a bluespice with docker using the official bluespice image, version 4.4.0
All is ok, except the search. I write several articles/pages, but when I try to do a search, it’s impossible to obtain any result.

The bar you are looging for is constantly moving without getting any result.

My host is Ubuntu 22.04.3 LTS

Any idea, please?

Hello and welcome to the BlueSpice community forums!

This actually looks like an issue with the search service. Are there maybe any hints in the logs?

can you try running sudo sysctl -w vm.max_map_count=262144 and then restarting the container again

1 Like

Hello jas.

I tried the command at the host, and after I reboot the container and the result is the same, the search bar progress is showed continually.

Hello rvogel.

The output of docker logs bluespice-container is the next:

Stopping Opensearch…
Starting Opensearch…
WAITING FOR 60 SECONDS BECAUSE OPENSEARCH NEEDS SOME TIME TO REALLY COME UP…
WARNING: A terminally deprecated method in java.lang.System has been called
WARNING: System::setSecurityManager has been called by org.opensearch.bootstrap.OpenSearch (file:/opt/opensearch/lib/opensearch-2.11.0.jar)
WARNING: Please consider reporting this to the maintainers of org.opensearch.bootstrap.OpenSearch
WARNING: System::setSecurityManager will be removed in a future release
WARNING: A terminally deprecated method in java.lang.System has been called
WARNING: System::setSecurityManager has been called by org.opensearch.bootstrap.Security (file:/opt/opensearch/lib/opensearch-2.11.0.jar)
WARNING: Please consider reporting this to the maintainers of org.opensearch.bootstrap.Security
WARNING: System::setSecurityManager will be removed in a future release

  • Restarting PHP 8.2 FastCGI Process Manager php-fpm8.2
    …done.
  • Restarting periodic command scheduler cron
  • Stopping periodic command scheduler cron
    …done.
  • Starting periodic command scheduler cron
    …done.
  • Restarting nginx nginx
    …done.

Hello

With the version 4.3.0 don’t exist this problem

But with the version 4.3.0 of BlueSpice (Docker) I obtain another error:

image

I would like to repair the search problem of the last version 4.4.0.

Thanks in advance. Any idea?

Finally, I don´t know why, the search process is working correctly. The only thing that I changed was the parameter vm.max_map_count=262144, but with this parameter changed, the result was wrong.

Thanks for the tips

Hello,
I’ve the same problem, SEARCH BAR, with a 4.4.0 installation, no DOCKER, on a Debian 12.
This is an update from a 4.2.4. The search bar worked properly before updating.
Any suggestions?

The search is changed in and from 4.4.0. Before 4.4.0, it was elasticsearch, but 4.4.0 and onwards it is opensearch. Setting sudo sysctl -w vm.max_map_count=262144 is important and will be updated in the README.md, thanks for pointing it out. Also to note that container should be given 7-8 minutes to start the opensearch service and rebuild the search indices to update everything and show the correct results.

Thank and any other feedback would be appreciated :raised_hands:

I have with newest build same Problem!
Can’t search anymore!

Hello.

I had this problem sometimes, and the only solution that I to find was to execute the next commands for rebuild the indexes.

It’s important that the file /etc/sysctl.conf of host server (Docker Server at my configuration) have the next configuration:

vm.max_map_count = 262144

If with this modification the problem is not resolved then to execute the next commands inside the bluespice server - the host or either inside the docker container.

php /data/www/bluespice/w/extensions/BlueSpiceExtendedSearch/maintenance/initBackends.php --quick

php /data/www/bluespice/w/extensions/BlueSpiceExtendedSearch/maintenance/rebuildIndex.php --quick

php /data/www/bluespice/w/maintenance/runJobs.php

Bye

1 Like