ExtendedSearch No Alive Nodes

Copied from:BlueSpice free / Support Requests / #217 ExtendedSearch No Alive Nodes.
Describe the issue / Steps to reproduce:
Using the instructions on its git page (as the instructions on the wiki page is woefully outdated), i’ve been trying to get BlueSpiceExtendedSearch to work but i’ve been running into a persistent issue that I can’t really make sense off.

I did the installation of OpenSearch as instructed, including the step of adding certificates to it, and then added ingest-attachment, put in the host, user and password variables in my LocalSettings.php.

But when I run the index scripts, I am immediately greeted the error from the errorBuilder image; Class "OpenSearch\ClientBuilder’ not found.

In accordance with the suggestions of OpenSearch itself, I ran

composer require opensearch-project/opensearch-php

Now I end up with the error of Error1 (No Alive Nodes), which is even more baffling given that I can clearly test my OpenSearch endpoints and get the expected returns from it indicating that I am running a cluster with a single node on it.

The bug persists on both REL1_9 and the latest release.

Does anyone have any idea on how to resolve this?

Expected behavior:
A clear description of what you expected to happen.

What was the error message/error log?
Class "OpenSearch\ClientBuilder’ not found.


System info:

  • BlueSpice version: 4.3

We have not officially released a version of BlueSpiceExtendedSearch yet. So officially only ElasticSearch 6.8 is supported.

With the upcoming BlueSpice version 4.4 (in ~6 weeks), we officially add support for OpenSearch 2.7

In you particular case, I believe you may need to run composer update within the extension directory.
We maintain the following branches

  • Regular Wikimedia LTS release branches, like REL1_35, REL1_39, REL1_43, …
  • BlueSpice release branches, like REL1_35-4.2.x, REL1_39-4.3.x, REL1_39-4.4.x, …
  • The master or main branch
    Releases (with version tag) are only done from the “BlueSpice release branches”. I recommend to only use actual version tag releases
    On the “Regular Wikimedia LTS release branches” we do feature development, but it is not officially released until there is a tagged version release.

Regarding your error: The code seems to be okay. Maybe there is just no connection to the OpenSearch service?

In the meantime BlueSpice 4.4 has been released. I t can be downloaded at BlueSpice free (Support archive) - Browse Files at SourceForge.net