ImportOfficeFile hangs on import

Describe the issue / Steps to reproduce:
Hi. I’m running Mediawiki 1.40 on Ubuntu 22.04 with XFCE desktop and Firefox 110.0. I mistakenly installed the extension for 1.41 but then deleted it from the Extensions folder and downloaded for 1.40 instead.

Expected behavior:
I tried importing a sample MS-Word .docx file using the 1.41 extension, and got ‘this file is banned’. I reverted to 1.40 and the file now imports but hangs at that point. I would expect to move to the setting screens. What have I missed or not done?

What was the error message/error log?
I cannot find anything in the Wiki logs relating to this action.

If applicable, add screenshots to help explain your problem.

System info:
view system requirements

  • OS: Ubuntu 22.04.1/Xfce 4.16
  • Server: Apache 2.4.52
  • PHP: 8.1.2-1ubuntu2.14
  • Database: MySQL 8.0.35-0ubuntu0.22.04.1
  • BlueSpice version: not used
  • Browser version: Firefox 110.0 and later Firefox 121.0
  • Hardware HP Z6 (Xeon Silver 4110 16-core, 32 GB RAM, AMD Radeon Pro graphics)

Hello and welcome to the BlueSpice Community forums!

You are probably missing the “Process Manager” setup step. Unfortunately, it is not well documented outside the BlueSpice ecosystem. My apologies.

Please find the required information here: GitHub - hallowelt/mwstake-mediawiki-component-processmanager

Please be aware that we usually only support LTS versions of MediaWiki, which would be 1.39 at the moment. It will most likely also work with a 1.40.

Also please make sure to install the extension using composer as it relies on some external libraries/components.

Hello again

I tried following your instructions but found problems with composer (doesn’t like to be run as root). So anyhow I decided to try Bluespice-free which I now have running at 4.4 (after having to change ownership of all wiki files to www-data).

However I cannot see any menu for importing office files, and indeed the extension is not there in the extensions folder. Do I have to add that manually?

This is true: Extension:ImportOfficeFiles is not included in the BlueSpice Free release.