# Visual Editor not loading after migration

**URL:** <https://community.bluespice.com/t/visual-editor-not-loading-after-migration/45>\
**Category:** Configuration/Setup\
**Created:** [December 7, 2023, 6:33pm UTC](https://community.bluespice.com/t/visual-editor-not-loading-after-migration/45 "2023-12-07T18:33:09Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![witharmshigh](https://dub1.discourse-cdn.com/flex017/user_avatar/community.bluespice.com/witharmshigh/32/28_2.png) [@witharmshigh](https://community.bluespice.com/u/witharmshigh)\
**Post date:** [December 7, 2023, 6:33pm UTC](https://community.bluespice.com/t/visual-editor-not-loading-after-migration/45/1 "2023-12-07T18:33:09Z")

</div>

**Describe the issue / Steps to reproduce:**  
i did a migration from Media Wiki to the latest 4.4 version today and the visual editor it not working.

I confirmed the steps here: [VisualEditor configuration - BlueSpice Wiki](https://en.wiki.bluespice.com/wiki/Setup:Installation_Guide/Advanced/VisualEditor_Configuration)

**Expected behavior:**  
the visual editor should load

**What was the error message/error log?**  
There is no error messages on the screen. The loading bar gets about 3/4 of the way across the screen and I get the following errors in the console:

```auto
[ZXIGCcGKdNWOeaR41pHcYgAAAAM] 2023-12-07 17:51:05: Fatal exception of type "RuntimeException"
(anonymous) @ load.php?lang=en&modules=ext.bluespice.watchlist.visualEditor&skin=bluespicediscovery&version=1o25a:4

```

and

```auto
ContentDroplets: Required RL modules failed to load
(anonymous) @ VM17:26

```

There are a lot of deprecated errors in the php\_error\_log file but nothing related to this that I can see.

**System info:**  
[view system requirements](https://en.wiki.bluespice.com/wiki/Setup:System_requirements)

- OS: unknown. hosting on [siteground.com](http://siteground.com)
- Server: unknown. hosting on [siteground.com](http://siteground.com)
- PHP: 8.2.13
- Database: MySQL 5.7.39
- BlueSpice version: BlueSpice free 4.4
- Browser version: Chrome: Version 119.0.6045.199

---

<div class="post-metadata">

**Author:** ![witharmshigh](https://dub1.discourse-cdn.com/flex017/user_avatar/community.bluespice.com/witharmshigh/32/28_2.png) [@witharmshigh](https://community.bluespice.com/u/witharmshigh)\
**Post date:** [December 10, 2023, 1:24am UTC](https://community.bluespice.com/t/visual-editor-not-loading-after-migration/45/2 "2023-12-10T01:24:11Z")

</div>

So i turned on some debugging and found the error for the VE was as follows:

```auto
"<PATH_TO_MY-WEBROOT>/w/extensions/BlueSpiceWatchList/resources/bs.watchlist/util/tag/WatchListDefinition.js"

```

The bs.watchlist is lowercase but on my server it was BS.WatchList and this was causing an error. after i renamed it to all lower case, cleared caches etc all is well with the world…

---

<div class="post-metadata">

**Author:** ![rvogel](https://avatars.discourse-cdn.com/v4/letter/r/eada6e/32.png) [@rvogel](https://community.bluespice.com/u/rvogel)\
**Post date:** [December 22, 2023, 9:21am UTC](https://community.bluespice.com/t/visual-editor-not-loading-after-migration/45/3 "2023-12-22T09:21:22Z")

</div>

FYI: This is a known issue on Windows server environments. There is an open bug report already. Reference is ERM34435.

See also `https://sourceforge.net/p/bluespice/support-requests/214/`
