# Fail with PDF export after migration to 5.2.6 Free

**URL:** <https://community.bluespice.com/t/fail-with-pdf-export-after-migration-to-5-2-6-free/449>\
**Category:** Configuration/Setup\
**Created:** [October 8, 2026, 8:25am UTC](https://community.bluespice.com/t/fail-with-pdf-export-after-migration-to-5-2-6-free/449 "2026-10-08T08:25:24Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Fernando](https://avatars.discourse-cdn.com/v4/letter/f/779978/32.png) [@Fernando](https://community.bluespice.com/u/Fernando)\
**Post date:** [October 8, 2026, 8:25am UTC](https://community.bluespice.com/t/fail-with-pdf-export-after-migration-to-5-2-6-free/449/1 "2026-10-08T08:25:25Z")

</div>

**Describe the issue / Steps to reproduce:**  
I had a docker free installation of BlueSpice 4.4 and now I migrated a new installation with BlueSpice 5.2.6. I import the database and copy the images. Basically I followed the links, the first to install and the second to migrate my database and images:

> **[Setup:Installation Guide/Docker - BlueSpice Helpdesk](https://en.wiki.bluespice.com/wiki/Setup:Installation_Guide/Docker)**

> **[Setup:Installation Guide/Update from 4.5 to 5.1/Classic tarball - BlueSpice...](https://en.wiki.bluespice.com/wiki/Setup:Installation_Guide/Update_from_4.5_to_5.1/Classic_tarball)**

All is correct except the email subject -discussed in another recent forum post- and the PDF Export.

When I go to PDF Export

 ![image](https://europe1.discourse-cdn.com/flex017/uploads/bluespice/original/1X/12fa82c46d45c6c7b759280c10e4fcb43a080fc2.png)

 ![image](https://europe1.discourse-cdn.com/flex017/uploads/bluespice/original/1X/538fbad74a61475ce0e93ae305f43b90be7fdd63.png)

When I try to enter at MediaWiki:PDFCreator/StandardPDF obtain the next error

 ![image](https://europe1.discourse-cdn.com/flex017/uploads/bluespice/original/1X/1dd1371668b70e4c061a63deef0b008c9d2842cf.png)

 ![image](https://europe1.discourse-cdn.com/flex017/uploads/bluespice/original/1X/a5f4fc4e8f49c61829a36bafb1ca7850e1d13f25.jpeg)

Any idea?

Thanks in advance

---

<div class="post-metadata">

**Author:** ![Fernando](https://avatars.discourse-cdn.com/v4/letter/f/779978/32.png) [@Fernando](https://community.bluespice.com/u/Fernando)\
**Post date:** [October 8, 2026, 5:12pm UTC](https://community.bluespice.com/t/fail-with-pdf-export-after-migration-to-5-2-6-free/449/2 "2026-10-08T17:12:06Z")

</div>

Hello. I found the problem. With docker logs bluespice-wiki-web | grep pdf I obtain erros as the next:

```auto
2026/10/08 10:11:45 [error] 58#58: *23351 FastCGI sent in stderr: "PHP message: [2026-10-08T08:11:44.929349+00:00] exception.ERROR: [067eae92781bac63d4368103] /wiki/MediaWiki:PDFCreator/StandardPDF MediaWiki\Storage\NameTableAccessException: Failed to access name from slot_roles using id = 3 {"exception":"[object] (MediaWiki\\Storage\\NameTableAccessException(code: 0): Failed to access name from slot_roles using id = 3 at /app/bluespice/w/includes/Storage/NameTableAccessException.php:41)","exception_url":"/wiki/MediaWiki:PDFCreator/StandardPDF","reqId":"067eae92781bac63d4368103","caught_by":"entrypoint"} 

```

I saw a problem with the id =3 for the table slot\_roles. At my migrated table slot\_roles I didn’t have a row with id=3.

My original migrated table slot\_roles

 ![image](https://europe1.discourse-cdn.com/flex017/uploads/bluespice/original/1X/f2da830243eae0e34ad15b92a47bd70d962d2d58.png)

I mounted a new clean installation at other server and then I can retrieve the values of the table -docker exec -it bluespice-database bash- and I saw the next viewing the database:

 ![image](https://europe1.discourse-cdn.com/flex017/uploads/bluespice/original/1X/74611a85b6127a4c56580fa4d9dedfd61a589ec3.png)

I imported the new values and then I can to generate a new pdf file from a wiki page.

Regards…

---

<div class="post-metadata">

**Author:** ![mlink-rodrigue](https://avatars.discourse-cdn.com/v4/letter/m/85e7bf/32.png) [@mlink-rodrigue](https://community.bluespice.com/u/mlink-rodrigue)\
**Post date:** [October 9, 2026, 2:36pm UTC](https://community.bluespice.com/t/fail-with-pdf-export-after-migration-to-5-2-6-free/449/3 "2026-10-09T14:36:37Z")

</div>

Hi Fernando,  
thanks for posting the solution and letting us know that you were able to figure out what caused the issue.

Greetings

Margit
